[Gens] LAN & Gens help

Announce and share your kaillera mods here.

Moderators: gothic_hobbit, civilian, okaygo, toqer

[Gens] LAN & Gens help

Postby U4EA » Thu Jul 24, 2003 4:40 am

I downloaded the latest version of the Kaillera server from the downloads section at this site. I'm using version 2.11 of Gens, which I believe is the latest.

I run the server exe on my more powerful machine, then connect to its LAN ip address from Gens on both machines. This works fine. I can also start games and join them and with some games, even manage to play them fine (Gunstar Heroes, WeaponLord, Sonic 3).

But for others, the machine I'm running the server on doesn't see anything. That is, everything works fine and the second machine runs fine and if I control a character from the first machine he moves around on the other machine. But Gens is completely blank on the server machine .. the screen is totally black. Instead of the game's name appearing on the titlebar there is random gibberish.

I know there are identical versions of Gens on both machines and all the game roms are there too (since I simply copied the folder over). The file names for the roms are also identical.

It seemingly doesn't matter which PC starts the game and which one joins it. I also tried running the server exe on the second machine .. but I still get the same problem .. some games work while others don't.

The games that don't work are: Golden Axe 3, Streets of Rage 2, X-Men 2 Clone Wars and Teenage Mutant Ninja Turtles.

Has anyone run into this sort of a problem before? I can provide more details like system specs and anything else you may want to know to get a better idea of what's up.

Cheers for your help 8)
U4EA
 

Postby U4EA » Thu Jul 24, 2003 10:00 pm

Alright .. I managed to fix it myself. It turns out that the games which had a save state in the Gens folder were the ones which weren't working. When I copied the Gens folder onto the second machine, I didn't copy the save state files. Deleting the save states from the Gens folder fixed the problem and everything is working fine.

I don't know if this is a Gens issue or a Kaillera issue so I'm posting this both here and at the Gens forums in the hope that the respective developers will have a look at this problem and see if they can't figure out what's up.

Cheers.
U4EA
 

Postby raleagh » Thu Dec 23, 2004 12:44 pm

where do you get server eve? i only have a client one and i want to play ove rmy lan
raleagh
 

Re: [Gens] LAN & Gens help

Postby gothic_hobbit » Sun Feb 22, 2015 4:43 pm

Bump
gothic_hobbit
Die-Hard Member
 
Posts: 272
Joined: Wed Apr 21, 2004 3:23 pm
Location: Hell


Return to Kaillera Modifications

Who is online

Users browsing this forum: No registered users and 1 guest